<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:fb="http://www.facebook.com/2008/fbml"
      xmlns:og="http://ogp.me/ns#"
      lang="en-us">
    <head>
      <script>
        var mp_global = {"fb_app_id": null, "section": "entertainment", "subsection": null, "urlname": "weekend-bar-specials-may-3-6", "tag": ["entertainment", "Food", "Bar", "Headline Story"], "instance": "cpwausau", "author": [], "type": "article"};
      </script>
      
      <script type="text/javascript">
(function(d) {
var config = {
  kitId: 'oim0ydb',
  scriptTimeout: 3000},h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(
/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement(
"script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";
tk.src='//use.typekit.net/'+config.kitId+'.js';tk.async=true;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;
f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)
})(document);
</script>
      <title>Find your WEEKEND BAR, FOOD &amp; FUN SPECIALS May 3-6 - City Pages</title>
      <meta name="generator" content="Metro Publisher (www.metropublisher.com)" />
      <meta name="viewport" content="width=device-width, initial-scale=1" />
      <meta itemprop="name" id="publisher-name" content="City Pages" />
      
        <script type="text/javascript">var _mp_require = {"config": {"js\/page_roundup": null, "js\/page_content": {"google_api_key": "AIzaSyBoGVWaCKsfiguJhpKVvbsD0SQaxnx57Vk", "back_title": "Return to \"Find your WEEKEND BAR, FOOD & FUN SPECIALS May 3-6\"", "show_occ_paginator": false, "is_pro": false, "media_gallery": {"slideshowCurrent": "{current} of {total}", "wh_sizes": [320, 480, 720, 1080, 1280, 1440, 1920], "slideshowStop": "Stop Slideshow", "slideshowStart": "Start Slideshow"}, "ctype": null, "comments_url": "http:\/\/www.thecitypages.com\/api\/content\/48f580e0-4324-11e8-9571-121bebc5777e\/get_comments", "media_support": {"slots": [{"slot_ord": 0, "slot_id": 3000, "slot_uuid": "a04771f5-2cea-4b82-826b-acc02655927c", "media_count": 1, "display_type": "aside"}, {"slot_ord": 1, "slot_id": 3001, "slot_uuid": "dd78be82-0807-46f8-f58b-a5144c4e486d", "media_count": 1, "display_type": "aside"}, {"slot_ord": 2, "slot_id": 3002, "slot_uuid": "03f994b1-c586-4dc7-a8b3-b0c4b4fd1c71", "media_count": 1, "display_type": "aside"}], "wh_sizes": [320, 480, 720, 1080, 1280, 1440, 1920]}, "tcomments": {"your_name": "Your Name", "subject_required": "Subject required", "fb_login": " or login with Facebook", "comment_required": "Comment required", "name_required": "Name required", "type_comment": "Type your comment here...", "email_invalid": "Invalid email address", "fb_logout": "Logout", "subject": "Type subject here...", "fb_app_id": null, "content_uuid": "48f580e0-4324-11e8-9571-121bebc5777e", "view_more": "View More", "submit": "Submit", "email_required": "Email required", "chars_left": "characters left", "comments": "Comments", "wrong_captchas": "Wrong Captchas", "ugc_allow_comments": false, "type_captchas": "Enter the word from the Image", "ugc_email_for_comments": false, "rss_feed": "Comment Feed", "email": "Email", "post_moderated": "Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.", "info_text": "All comments are moderated and generally will be posted if they are on-topic and not abusive.", "post_success": "Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.", "post_to_wall": "Publish comment to your Wall"}, "related_links_url": "http:\/\/www.thecitypages.com\/api\/content\/48f580e0-4324-11e8-9571-121bebc5777e\/get_related_links"}}, "paths": {"facebook": "\/\/connect.facebook.net\/en_US\/sdk"}, "baseUrl": "https:\/\/d2az0yupc2akbm.cloudfront.net\/vanguardistas.publicview\/4.113.post6212.dev883034347365\/static\/", "shim": {"facebook": {"exports": "FB"}}};</script>
<script
  id="requirejs"
  src="https://d3t13abgv0q40.cloudfront.net/mp-public/js/require-jquery.bbdcab34b563441ac2b91d548bf4ab20.js"></script>


        
      
      <meta name="description" content="Go out! Wausau area happy hours, food and live entertainment specials, Thurs.-Sun. May 3-6"/>
      <meta name="keywords" content="entertainment,Food,Bar,Headline Story"/>
      <link rel="manifest" href="/manifest.json">
      
      <meta name="thumbnail" content="http://www.thecitypages.com/downloads/952/download/BarSpecial_Icons.jpg?cb=122960bda03ce5e4b27d7e024ddd7235"/>
      <link rel="canonical" href="http://www.thecitypages.com/entertainment/weekend-bar-specials-may-3-6/"/>

      <link href="http://www.thecitypages.com/api/rss/content.rss" rel="alternate" type="application/rss+xml" title="Find your WEEKEND BAR, FOOD &amp; FUN SPECIALS May 3-6 - City Pages" />
      

      <link rel="stylesheet" type="text/css" href="https://d3t13abgv0q40.cloudfront.net/mp-public/css/theme-newsy.daebfc0c6faa66559b872b0b6dfa2665.css"/>
      <link rel="stylesheet" type="text/css" href="http://www.thecitypages.com/api/design-89a15569a9c49974692c8f3374c3ab79/screen.css"/>
      
      <script src="https://d3t13abgv0q40.cloudfront.net/mp-public/js/mp.7fb28ecc4f2fa7f7997e8892074563fc.js" async="true"></script>
      <link rel="shortcut icon" href="http://www.thecitypages.com/api/design-89a15569a9c49974692c8f3374c3ab79/favicon.ico"/>

      <!-- Google Analytics -->
<script>
window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
ga('create', 'UA-82768842-1', 'auto');
ga('require', 'displayfeatures');
ga('send', 'pageview');
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<!-- End Google Analytics -->
      
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];



(function() {
  var resizeTimer;
  var windowwidth = window.innerWidth;
  function resizer() {
      googletag.pubads().refresh();
  }

  window.addEventListener("resize", function(){ 
      if (window.innerWidth != windowwidth) {
          windowwidth = window.innerWidth;
          clearTimeout(resizeTimer);
          resizeTimer = setTimeout(resizer, 250);
      }
  });
})();


googletag.cmd.push(function() {
  var target_keys = ['tag', 'type', 'instance', 'section', 'subsection', 'urlname'],
        i;
  for (i = 0; i < target_keys.length; i++) {
      googletag.pubads().setTargeting(target_keys[i], mp_global[target_keys[i]]);
  }

  var leaderboard_mapping = googletag.sizeMapping().
addSize([0, 0], [[320, 50], [300, 50]]).
addSize([750, 200], [728, 90]).
addSize([1050, 250], [[970, 90], [970, 250]]).
build();

var billboard_mapping = googletag.sizeMapping().
addSize([0, 0], []).
addSize([970, 250], [970, 250]).
build();

var wallpaper_right_mapping = googletag.sizeMapping().
addSize([0, 0], []).
addSize([1000, 0], [160, 600]).
build();

var mpu_mapping = googletag.sizeMapping().
addSize([0, 0], [[300, 250], [300, 600]]).
build();

var wallpaper_left_mapping = googletag.sizeMapping().
addSize([0, 0], []).
addSize([1000, 0], [160, 600]).
build();


  
  
  googletag.defineSlot('28252308/mp_leaderboard_nav', [728, 90], 'leaderboard_nav').defineSizeMapping(leaderboard_mapping).addService(googletag.pubads());
  googletag.defineSlot('28252308/mp_wallpaper_left', [160, 600], 'wallpaper_left').defineSizeMapping(wallpaper_left_mapping).addService(googletag.pubads());
  googletag.defineSlot('28252308/mp_wallpaper_right', [160, 600], 'wallpaper_right').defineSizeMapping(wallpaper_right_mapping).addService(googletag.pubads());
  googletag.defineSlot('28252308/mp_leaderboard_top', [728, 90], 'leaderboard_top').defineSizeMapping(leaderboard_mapping).addService(googletag.pubads());
  googletag.defineSlot('28252308/mp_mpu_right', [300, 250], 'mpu_right').defineSizeMapping(mpu_mapping).addService(googletag.pubads());
  googletag.defineSlot('28252308/mp_leaderboard_bottom', [728, 90], 'leaderboard_bottom').defineSizeMapping(leaderboard_mapping).addService(googletag.pubads());

  
  

  googletag.pubads().enableSingleRequest();


  googletag.pubads().collapseEmptyDivs(true);
  googletag.enableServices();


  var last_refresh = Date.now();
  document.addEventListener('refresh_ads', function () {
    if (Date.now() - last_refresh > 1000) {
        last_refresh = Date.now();
        googletag.pubads().refresh();
    }
  });


});
</script>

      <meta property="og:title" content="Find your WEEKEND BAR, FOOD &amp; FUN SPECIALS May 3-6"/><meta property="og:description" content="Go out! Wausau area happy hours, food and live entertainment specials, Thurs.-Sun. May 3-6"/><meta property="og:url" content="http://www.thecitypages.com/api/content/48f580e0-4324-11e8-9571-121bebc5777e/"/><meta property="og:image" content="http://www.thecitypages.com/downloads/952/download/BarSpecial_Icons.jpg?cb=122960bda03ce5e4b27d7e024ddd7235"/><meta property="og:image:width" content="700"/><meta property="og:image:height" content="369"/><meta property="og:image" content="http://www.thecitypages.com/downloads/1039/download/Sconnis_logo.jpg?cb=646a55b9865e7090582b6ca2af9fa669"/><meta property="og:image:width" content="315"/><meta property="og:image:height" content="293"/><meta property="og:image" content="http://www.thecitypages.com/downloads/2115/download/ArrowSportClub2_logo.jpg?cb=6a8247bcea16219fb6d10e18e9ef098c"/><meta property="og:image:width" content="300"/><meta property="og:image:height" content="189"/><meta property="og:image" content="http://www.thecitypages.com/downloads/2110/download/Malarkeys_LogoGood.jpg?cb=87a5ab86cd0c618c41b75da32f1aab6d"/><meta property="og:image:width" content="300"/><meta property="og:image:height" content="288"/><meta property="og:type" content="article"/><meta property="og:site_name" content="City Pages"/>
      <meta name="author" content=""/><meta property="article:tag" content="entertainment"/><meta property="article:tag" content="Food"/><meta property="article:tag" content="Bar"/><meta property="article:tag" content="Headline Story"/><meta property="article:published_time" content="2018-05-03T10:00:00"/>
      

      

      

      

      
      
      <style> a.RSS_link {display:none} </style>
        
        
        

      <meta id="worstRating" itemprop="worstRating" content="0" />
      <meta id="bestRating" itemprop="bestRating" content="5" />
    </head>
  <body class="mp-type-article mp-sidebar">
      

    <div id="body">
    <a class="skip-to-main" href="#maincontent">Skip to main content</a>
    <div id="wallpaper_left">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('wallpaper_left'); });
 </script>
</div>

    
      
        <div id="section_entertainment">
          <div id="subsection_website">
      <div id="page">




        <div id="top">
          <div id="topads">

            <div id="topad1">
              <div id="leaderboard_top">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('leaderboard_top'); });
 </script>
</div>

            </div>

            

          </div>
          
<div id="logo">
  
  <div id="mp-search-bar">
    <form action="http://www.thecitypages.com/api/search.html">
      <input type="text" name="q" title="Enter Search Words" placeholder="Search..." />
      <button class="search submit" type="submit" name="sa">Search</button>
    </form>
  </div>
  <div class="logo">
  <!--div class="header_links" tal:condition="python: header_links or socialmedia_urls"-->
    <div class="header_links">
        
            <a href="http://www.thecitypages.com/advertise">Advertise</a>
        
            <a href="http://www.thecitypages.com/about">About</a>
        
    </div>
    <div class="chicklets">
        
        <a href="https://www.facebook.com/wausaucitypages/" class="chicklet facebook" target="_blank">facebook</a>
        <a href="https://twitter.com/wausaucitypages" class="chicklet twitter" target="_blank">twitter</a>
        <a href="https://www.instagram.com/wausaucitypages/" class="chicklet instagram" target="_blank">instagram</a>
        <a href="/api/rss/content.rss" class="chicklet rss" rel="alternate">RSS</a>
    </div>
  <a rel="home" href="http://www.thecitypages.com" title="City Pages"><img src="http://www.thecitypages.com/api/design-89a15569a9c49974692c8f3374c3ab79/CP%20Wisco%20Banner.png" class="standard" alt="City Pages" title="City Pages" />
    <meta id="logo-url" itemprop="url" content="http://www.thecitypages.com/api/design-89a15569a9c49974692c8f3374c3ab79/CP%20Wisco%20Banner.png" />
    <meta id="logo-width" itemprop="width" content="3958" />
    <meta id="logo-height" itemprop="height" content="625" />
    <meta id="publisher-logo" itemprop="logo" itemscope="" itemtype="http://schema.org/ImageObject"
        itemref="logo-url logo-width logo-height" />
                                                                       <img src="http://www.thecitypages.com/api/design-89a15569a9c49974692c8f3374c3ab79/Mobile%20CP%20Wisco%20Banner.png" class="responsive" alt="City Pages" title="City Pages" /></a>
</div>

</div>

<nav id="topnav">
  <a href="#" class="pull">Menu</a>
  
<ul class="mainnav">
  <li class="menu_section_start menu_section_home">
	<a href="/">Home</a>
    
  </li>
  <li class="menu_section_news-opinion">
	<a href="http://www.thecitypages.com/news-opinion">News &amp; Opinion</a>
    
  </li>
  <li class="selected menu_section_entertainment">
	<a href="http://www.thecitypages.com/entertainment">Entertainment<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_end menu_subsection_event-calendar">
        <a href="/search/event/upcoming-events/">Event Calendar</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_Food__Drink__Shop">
	<a href="http://www.thecitypages.com/Food_Drink_Shop">Food/Drink/Shop</a>
    
  </li>
  <li class="menu_section_end menu_section_boring-but-important">
	<a href="http://www.thecitypages.com/boring-but-important">Boring but Important<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_officials">
        <a href="/boring-but-important/officials/elected-officials/">Elected Officials</a>
      </li>
      <li class="menu_subsection_schools">
        <a href="/boring-but-important/schools/wausau/">Schools</a>
      </li>
      <li class="menu_subsection_elections">
        <a href="/boring-but-important/elections/elections/">Gov. Offices &amp; Elections</a>
      </li>
      <li class="menu_subsection_end menu_subsection_garbage-recycling">
        <a href="/boring-but-important/garbage-recycling/garbage-recycling/">Garbage &amp; Recycling</a>
      </li>
    </ul>
  </li>
</ul>
<ul class="subnav">
  <li class="menu_subsection_start menu_subsection_end menu_subsection_event-calendar">
    <a href="/search/event/upcoming-events/">Event Calendar</a>
  </li>
</ul>


</nav>


        </div>
        <div id="leaderboard_nav">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('leaderboard_nav'); });
 </script>
</div>

        <div id="breadcrumbs"><a href="http://www.thecitypages.com">Home</a> <a href="http://www.thecitypages.com/entertainment">Entertainment</a> <a href="http://www.thecitypages.com/entertainment/weekend-bar-specials-may-3-6/">Find your WEEKEND BAR, FOOD &amp; FUN SPECIALS May 3-6</a></div>
        <main id="maincontent" role="main" tabindex="-1">

  
<div id="pagetype_article">


    <meta id="content-image-url" itemprop="url" content="http://www.thecitypages.com/downloads/952/download/BarSpecial_Icons.jpg?cb=122960bda03ce5e4b27d7e024ddd7235" />
    <meta id="content-image-width" itemprop="width" content="700" />
    <meta id="content-image-height" itemprop="height" content="369" />







  <article id="main" itemscope="" itemtype="http://schema.org/Article">

<nav class="sectionpaging"><p class="prev"><a rel="prev" href="http://www.thecitypages.com/entertainment/highlights-may-4-6/">HIGHLIGHTS: May 4-6</a></p>

</nav>

          <header><div id="title">
            <meta itemprop="name" content="Find your WEEKEND BAR, FOOD &amp; FUN SPECIALS May 3-6" />
            <meta itemprop="description" content="Go out! Wausau area happy hours, food and live entertainment specials, Thurs.-Sun. May 3-6" />
            <meta itemprop="publisher"
                  itemscope=""
                  itemtype="http://schema.org/Organization"
                  itemref="publisher-name publisher-logo" />
            <meta itemprop="dateModified" content="2018-05-03T10:51:22.381854" />
            <h1 itemprop="headline">Find your WEEKEND BAR, FOOD &amp; FUN SPECIALS May 3-6</h1>
            
            
                <meta itemprop="image" itemscope="" itemtype="http://schema.org/ImageObject"
                  itemref="content-image-url content-image-width content-image-height" />

                
            
          </div>
          
          <div id="pageinfos" class="pageinfos">
    
    <span style="display: none" itemprop="author" itemscope="" itemtype="http://schema.org/Organization" content=""><meta itemprop="name" content="City Pages" /></span>
    <time itemprop="datePublished" datetime="2018-05-03T10:00:00">
    <p class="date">May 3, 2018</p>
    <p class="time">10:00 AM</p></time>
</div>

</header>
<div id="backlink_container" style="display:none"><a href="" id="backlink">Back to Search Results</a></div>
<aside class="tools">
    <div id="fb-top" data-show_like="True" data-show_share="True" data-like_url="http://www.thecitypages.com/api/content/48f580e0-4324-11e8-9571-121bebc5777e/"></div>
    
    <div class="share"><a class="RSS_link" href="http://www.thecitypages.com/entertainment/index.rss">RSS</a></div>
    <div class="share"><a class="print" href="#" onclick="javascript: window.print(); return false;" target="_self">Print</a></div>

</aside>



    

    <div id="content" class="carousel content no_js" data-transition="content" itemprop="articleBody">


     <div>

    <h2>Go out! Wausau area happy hours, food and live entertainment specials, Thurs.-Sun. May 3-6</h2>&#13;
&#13;
<hr>&#13;
<div id="media-carousel-3000" class="media-aside">    <div class="gallery_slide single" id="media-thumb-3000-1" style="">            <div class="gallery_item group3000 " id="ms_3000-0" data-slot-media-path="/api/slot_media/3329/"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Sconni's" data-src="http://www.thecitypages.com/downloads/1039/download/Sconnis_logo.jpg?cb=646a55b9865e7090582b6ca2af9fa669&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 315]" src="http://www.thecitypages.com/downloads/1039/download/Sconnis_logo.jpg?cb=646a55b9865e7090582b6ca2af9fa669"><div class=""><!--need something here--></div></div>        </div></div><h2><a href="https://www.facebook.com/Sconnis-Alehouse-and-Eatery-733164110038480/" target="_blank">Sconni's </a></h2>&#13;
&#13;
<p><small>1239 Schofield Ave., Schofield  715-241-7665</small></p>&#13;
&#13;
<p><strong>HAPPY HOUR MON.-THURS.</strong>: $2 off all Craft Beer, 3-6pm</p>&#13;
&#13;
<p><strong>Come check out our extensive CRAFT COCKTAIL MENU</strong>. We brew our own bitters, hand squeeze our own citrus and use only house-made syrup in our cocktails.</p>&#13;
&#13;
<p><strong>MENU </strong>is LOCALLY SOURCED and many dishes are prepared with a variety of LOCALLY CRAFTED beers.</p>&#13;
&#13;
<p><strong>New SUNDAY BRUNCH </strong>9am-3pm, bar closes at 4pm</p>&#13;
&#13;
<hr>&#13;
<div id="media-carousel-3001" class="media-aside">    <div class="gallery_slide single" id="media-thumb-3001-1" style="">            <div class="gallery_item group3001 " id="ms_3001-0" data-slot-media-path="/api/slot_media/3330/"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="ArrowSportClub2_logo.jpg" data-src="http://www.thecitypages.com/downloads/2115/download/ArrowSportClub2_logo.jpg?cb=6a8247bcea16219fb6d10e18e9ef098c&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 300]" src="http://www.thecitypages.com/downloads/2115/download/ArrowSportClub2_logo.jpg?cb=6a8247bcea16219fb6d10e18e9ef098c"><div class=""><!--need something here--></div></div>        </div></div><h2><a href="https://www.facebook.com/arrowsportsclubweston/" target="_blank">Arrow Sports Bar</a></h2>&#13;
&#13;
<p><small>6202 Schofield Ave, Schofield  715-359-2363</small></p>&#13;
&#13;
<p><strong>HAPPY HOUR </strong>Mon.-Thurs. 3-6pm</p>&#13;
&#13;
<p><strong>$2 </strong>Domestic Beer during <strong>MILWAUKEE BREWER </strong>games all season long</p>&#13;
&#13;
<p><strong>Thursday $6.95 meatloaf </strong>with mashed potatoes, gravy, and veggies! 11am-3pm • <strong>$2 cheeseburgers </strong>4pm-8pm • $2 shots, $3.50 bombs</p>&#13;
&#13;
<p><strong>Friday </strong>$4 Old Fashioneds • Fish Fry</p>&#13;
&#13;
<p><strong>Saturday </strong>$5 Tall Flavored Vodkas • 25 cent boneless and 60 cent bone-in wings • LIVE MUSIC with <strong>Vada’s Rockhouse </strong>playing rock at 8:30pm</p>&#13;
&#13;
<p><strong>Sunday </strong>$5 Tall Titos Vodka</p>&#13;
&#13;
<hr>&#13;
<div id="media-carousel-3002" class="media-aside">    <div class="gallery_slide single" id="media-thumb-3002-1" style="">            <div class="gallery_item group3002 " id="ms_3002-0" data-slot-media-path="/api/slot_media/3331/"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Malarkeys_LogoGood.jpg" data-src="http://www.thecitypages.com/downloads/2110/download/Malarkeys_LogoGood.jpg?cb=87a5ab86cd0c618c41b75da32f1aab6d&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 300]" src="http://www.thecitypages.com/downloads/2110/download/Malarkeys_LogoGood.jpg?cb=87a5ab86cd0c618c41b75da32f1aab6d"><div class=""><!--need something here--></div></div>        </div></div><h2><a href="https://www.facebook.com/TowniesGrill/" target="_blank">Townies Grill</a>/ <a href="https://www.facebook.com/MalarkeysWausau/" target="_blank">Malarkey’s Pub</a></h2>&#13;
&#13;
<p><small>412 Third St., downtown Wausau 715-819-3663</small></p>&#13;
&#13;
<p><strong>Open for lunch and dinner </strong>Tues.-Sat. (plus Sunday brunch).</p>&#13;
&#13;
<p><strong>Happy Hour Tues.-Fri.</strong>: First drink free with purchase of ANY appetizer, 3-6pm (for drinks up to $5 value)</p>&#13;
&#13;
<p><strong>Friday </strong>LIVE MUSIC with <strong>Alex Rossi </strong>playing R&amp;B, funk and rock at 10pm</p>&#13;
&#13;
<p><strong>Saturday </strong>LIVE MUSICwith <strong>Brad Emanuel </strong>playing variety at 9pm</p>&#13;
&#13;
<p><strong>Sunday FEED THE SAU </strong>with all proceed going to Neighbor’s Place</p>&#13;
&#13;
<p><strong>You’ll love our SUNDAY BRUNCH</strong> Eggs benedict burger, French toast, eggs &amp; ham, kids menu and chef specials. 10am-3pm</p>&#13;


    

    </div>



    </div>


  



    
        
      
    



<aside class="tags">
<h4>Tags</h4>
                <a href="http://www.thecitypages.com/topics/entertainment/" rel="tag" >entertainment</a>

                <a href="http://www.thecitypages.com/topics/food/" rel="tag" >Food</a>

                <a href="http://www.thecitypages.com/topics/bar/" rel="tag" >Bar</a>

                <a href="http://www.thecitypages.com/topics/headline-story/" rel="tag" >Headline Story</a>

</aside>


<aside id="bottompageinfos" class="pageinfos">
    
    
    <time datetime="2018-05-03T10:00:00">
    <p class="date">May 3, 2018</p>
    <p class="time">10:00 AM</p>
    </time>
</aside>



<aside id="related"></aside>



  </article>

  

  <aside id="side">
    <div id="rightads"><div id="mpu_right">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('mpu_right'); });
 </script>
</div>
</div>

        

    <div class="slot">

  <div class="sprocket sprocket_image"><a href="http://www.thecitypages.com/circulation-data/" title="Find us"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Pick Us Up!" data-src="http://www.thecitypages.com/downloads/250/download/CP-Pick-Up-Papers-MPU.jpg?cb=883a441fa80a7020391998ae7cc0d58d&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 300]" src="http://www.thecitypages.com/downloads/250/download/CP-Pick-Up-Papers-MPU.jpg?cb=883a441fa80a7020391998ae7cc0d58d" /></a><p class="mp-credits"></p></div>


  <div class="sprocket sprocket_image"><a href="http://www.thecitypages.com/entertainment/weekend-bar-specials-may-3-6/" title="Online Bar Specials"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Online Bar Specials" data-src="http://www.thecitypages.com/downloads/2497/download/Untitled-2.jpg?cb=d4f9d15bf0e9ee0c7d38c51844789b05&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 660, 900]" src="http://www.thecitypages.com/downloads/2497/download/Untitled-2.jpg?cb=d4f9d15bf0e9ee0c7d38c51844789b05&amp;w=300" /></a><p class="mp-credits"></p></div>


  <div class="sprocket sprocket_image"><a href="http://www.thecitypages.com/entertainment/highlights-may-4-6/" title="Highlights Bar"><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Highlights 050318" data-src="http://www.thecitypages.com/downloads/2714/download/Highlights%20050318.png?cb=c4bf18f1d4a4d8f89da56d33f5653319&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 320, 450, 660, 1250]" src="http://www.thecitypages.com/downloads/2714/download/Highlights%20050318.png?cb=c4bf18f1d4a4d8f89da56d33f5653319&amp;w=300" /></a><p class="mp-credits"></p></div>


  <div class="sprocket sprocket_image"><a href="http://www.thecitypages.com/search/event/upcoming-events/" title=" "><img sizes="auto" srcset="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" class="mp-lazyload" alt="Calendar Header" data-src="http://www.thecitypages.com/downloads/2506/download/Calendar%20Header.png?cb=74c1ee017481f6cd4b0522020b58db84&amp;w={width}&amp;h={height}" data-widths="[100, 150, 220, 300]" src="http://www.thecitypages.com/downloads/2506/download/Calendar%20Header.png?cb=74c1ee017481f6cd4b0522020b58db84" /></a><p class="mp-credits"></p></div>


</div>

    
  </aside>
  
  </div>

  


</main>

        <div id="bottom">
          <div id="bottomads">
            <div id="leaderboard_bottom">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('leaderboard_bottom'); });
 </script>
</div>

          </div>
          
  
    <nav id="bottomnav">
      
<ul class="mainnav">
  <li class="menu_section_start menu_section_home">
	<a href="/">Home</a>
    
  </li>
  <li class="menu_section_news-opinion">
	<a href="http://www.thecitypages.com/news-opinion">News &amp; Opinion</a>
    
  </li>
  <li class="selected menu_section_entertainment">
	<a href="http://www.thecitypages.com/entertainment">Entertainment<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_end menu_subsection_event-calendar">
        <a href="/search/event/upcoming-events/">Event Calendar</a>
      </li>
    </ul>
  </li>
  <li class="menu_section_Food__Drink__Shop">
	<a href="http://www.thecitypages.com/Food_Drink_Shop">Food/Drink/Shop</a>
    
  </li>
  <li class="menu_section_end menu_section_boring-but-important">
	<a href="http://www.thecitypages.com/boring-but-important">Boring but Important<span class="nav_handle"></span></a>
    <ul class="subnav_nested">
      <li class="menu_subsection_start menu_subsection_officials">
        <a href="/boring-but-important/officials/elected-officials/">Elected Officials</a>
      </li>
      <li class="menu_subsection_schools">
        <a href="/boring-but-important/schools/wausau/">Schools</a>
      </li>
      <li class="menu_subsection_elections">
        <a href="/boring-but-important/elections/elections/">Gov. Offices &amp; Elections</a>
      </li>
      <li class="menu_subsection_end menu_subsection_garbage-recycling">
        <a href="/boring-but-important/garbage-recycling/garbage-recycling/">Garbage &amp; Recycling</a>
      </li>
    </ul>
  </li>
</ul>
<ul class="subnav">
  <li class="menu_subsection_start menu_subsection_end menu_subsection_event-calendar">
    <a href="/search/event/upcoming-events/">Event Calendar</a>
  </li>
</ul>


    </nav>

    <div id="textnav">
      <ul>
  <li class="menu_section_start "
    >
    <a href="http://www.thecitypages.com/advertise">Advertise</a>
  </li>
  <li class="menu_section_end"
    >
    <a href="http://www.thecitypages.com/about">About</a>
  </li>
</ul>

    </div>
  
  

  <div id="copyright">
    <p></p>
  </div>

  <div id="mp_credits">
    Built with <a href="https://www.metropublisher.com" target="new">Metro Publisher&#8482;</a>
  </div>




        </div>

      </div>
      </div>
      </div>
      
    
    <div id="wallpaper_right">
 <script type="text/javascript">
     googletag.cmd.push(function() { googletag.display('wallpaper_right'); });
 </script>
</div>

    </div>
  
  
  
  
    
  

    

    
       <script async defer src="//connect.facebook.net/en_US/sdk.js" ></script>
    

    

    <span id="mp-config" data-js="{&quot;_mp_page_content&quot;: {&quot;google_api_key&quot;: &quot;AIzaSyBoGVWaCKsfiguJhpKVvbsD0SQaxnx57Vk&quot;, &quot;back_title&quot;: &quot;Return to \&quot;Find your WEEKEND BAR, FOOD &amp; FUN SPECIALS May 3-6\&quot;&quot;, &quot;show_occ_paginator&quot;: false, &quot;is_pro&quot;: false, &quot;media_gallery&quot;: {&quot;slideshowCurrent&quot;: &quot;{current} of {total}&quot;, &quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920], &quot;slideshowStop&quot;: &quot;Stop Slideshow&quot;, &quot;slideshowStart&quot;: &quot;Start Slideshow&quot;}, &quot;ctype&quot;: null, &quot;comments_url&quot;: &quot;http://www.thecitypages.com/api/content/48f580e0-4324-11e8-9571-121bebc5777e/get_comments&quot;, &quot;media_support&quot;: {&quot;slots&quot;: [{&quot;slot_ord&quot;: 0, &quot;slot_id&quot;: 3000, &quot;slot_uuid&quot;: &quot;a04771f5-2cea-4b82-826b-acc02655927c&quot;, &quot;media_count&quot;: 1, &quot;display_type&quot;: &quot;aside&quot;}, {&quot;slot_ord&quot;: 1, &quot;slot_id&quot;: 3001, &quot;slot_uuid&quot;: &quot;dd78be82-0807-46f8-f58b-a5144c4e486d&quot;, &quot;media_count&quot;: 1, &quot;display_type&quot;: &quot;aside&quot;}, {&quot;slot_ord&quot;: 2, &quot;slot_id&quot;: 3002, &quot;slot_uuid&quot;: &quot;03f994b1-c586-4dc7-a8b3-b0c4b4fd1c71&quot;, &quot;media_count&quot;: 1, &quot;display_type&quot;: &quot;aside&quot;}], &quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920]}, &quot;tcomments&quot;: {&quot;your_name&quot;: &quot;Your Name&quot;, &quot;subject_required&quot;: &quot;Subject required&quot;, &quot;fb_login&quot;: &quot; or login with Facebook&quot;, &quot;comment_required&quot;: &quot;Comment required&quot;, &quot;name_required&quot;: &quot;Name required&quot;, &quot;type_comment&quot;: &quot;Type your comment here...&quot;, &quot;email_invalid&quot;: &quot;Invalid email address&quot;, &quot;fb_logout&quot;: &quot;Logout&quot;, &quot;subject&quot;: &quot;Type subject here...&quot;, &quot;fb_app_id&quot;: null, &quot;content_uuid&quot;: &quot;48f580e0-4324-11e8-9571-121bebc5777e&quot;, &quot;view_more&quot;: &quot;View More&quot;, &quot;submit&quot;: &quot;Submit&quot;, &quot;email_required&quot;: &quot;Email required&quot;, &quot;chars_left&quot;: &quot;characters left&quot;, &quot;comments&quot;: &quot;Comments&quot;, &quot;wrong_captchas&quot;: &quot;Wrong Captchas&quot;, &quot;ugc_allow_comments&quot;: false, &quot;type_captchas&quot;: &quot;Enter the word from the Image&quot;, &quot;ugc_email_for_comments&quot;: false, &quot;rss_feed&quot;: &quot;Comment Feed&quot;, &quot;email&quot;: &quot;Email&quot;, &quot;post_moderated&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;info_text&quot;: &quot;All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;post_success&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;post_to_wall&quot;: &quot;Publish comment to your Wall&quot;}, &quot;related_links_url&quot;: &quot;http://www.thecitypages.com/api/content/48f580e0-4324-11e8-9571-121bebc5777e/get_related_links&quot;}, &quot;_mp_facebook_&quot;: true}"/><script async src="https://d3t13abgv0q40.cloudfront.net/mp-public/js/page_content.deec8f764dc4cb6188e34a8cf9625805.js" data-config="{&quot;google_api_key&quot;: &quot;AIzaSyBoGVWaCKsfiguJhpKVvbsD0SQaxnx57Vk&quot;, &quot;back_title&quot;: &quot;Return to \&quot;Find your WEEKEND BAR, FOOD &amp; FUN SPECIALS May 3-6\&quot;&quot;, &quot;show_occ_paginator&quot;: false, &quot;is_pro&quot;: false, &quot;media_gallery&quot;: {&quot;slideshowCurrent&quot;: &quot;{current} of {total}&quot;, &quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920], &quot;slideshowStop&quot;: &quot;Stop Slideshow&quot;, &quot;slideshowStart&quot;: &quot;Start Slideshow&quot;}, &quot;ctype&quot;: null, &quot;comments_url&quot;: &quot;http://www.thecitypages.com/api/content/48f580e0-4324-11e8-9571-121bebc5777e/get_comments&quot;, &quot;media_support&quot;: {&quot;slots&quot;: [{&quot;slot_ord&quot;: 0, &quot;slot_id&quot;: 3000, &quot;slot_uuid&quot;: &quot;a04771f5-2cea-4b82-826b-acc02655927c&quot;, &quot;media_count&quot;: 1, &quot;display_type&quot;: &quot;aside&quot;}, {&quot;slot_ord&quot;: 1, &quot;slot_id&quot;: 3001, &quot;slot_uuid&quot;: &quot;dd78be82-0807-46f8-f58b-a5144c4e486d&quot;, &quot;media_count&quot;: 1, &quot;display_type&quot;: &quot;aside&quot;}, {&quot;slot_ord&quot;: 2, &quot;slot_id&quot;: 3002, &quot;slot_uuid&quot;: &quot;03f994b1-c586-4dc7-a8b3-b0c4b4fd1c71&quot;, &quot;media_count&quot;: 1, &quot;display_type&quot;: &quot;aside&quot;}], &quot;wh_sizes&quot;: [320, 480, 720, 1080, 1280, 1440, 1920]}, &quot;tcomments&quot;: {&quot;your_name&quot;: &quot;Your Name&quot;, &quot;subject_required&quot;: &quot;Subject required&quot;, &quot;fb_login&quot;: &quot; or login with Facebook&quot;, &quot;comment_required&quot;: &quot;Comment required&quot;, &quot;name_required&quot;: &quot;Name required&quot;, &quot;type_comment&quot;: &quot;Type your comment here...&quot;, &quot;email_invalid&quot;: &quot;Invalid email address&quot;, &quot;fb_logout&quot;: &quot;Logout&quot;, &quot;subject&quot;: &quot;Type subject here...&quot;, &quot;fb_app_id&quot;: null, &quot;content_uuid&quot;: &quot;48f580e0-4324-11e8-9571-121bebc5777e&quot;, &quot;view_more&quot;: &quot;View More&quot;, &quot;submit&quot;: &quot;Submit&quot;, &quot;email_required&quot;: &quot;Email required&quot;, &quot;chars_left&quot;: &quot;characters left&quot;, &quot;comments&quot;: &quot;Comments&quot;, &quot;wrong_captchas&quot;: &quot;Wrong Captchas&quot;, &quot;ugc_allow_comments&quot;: false, &quot;type_captchas&quot;: &quot;Enter the word from the Image&quot;, &quot;ugc_email_for_comments&quot;: false, &quot;rss_feed&quot;: &quot;Comment Feed&quot;, &quot;email&quot;: &quot;Email&quot;, &quot;post_moderated&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;info_text&quot;: &quot;All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;post_success&quot;: &quot;Comment successfully submitted. All comments are moderated and generally will be posted if they are on-topic and not abusive.&quot;, &quot;post_to_wall&quot;: &quot;Publish comment to your Wall&quot;}, &quot;related_links_url&quot;: &quot;http://www.thecitypages.com/api/content/48f580e0-4324-11e8-9571-121bebc5777e/get_related_links&quot;}" id="_mp_page_content"></script>

  </body>
</html>
